summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff8c9efba46d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Migliore <mcmigliore+aur@gmail.com>
+# Maintainer: Mathieu Wespthal <mathieu.westphal+aur@gmail.com>
+
+export GIT_LFS_SKIP_SMUDGE=1
+_name=f3d
+_plugin=draco
+pkgname=$_name-plugin-$_plugin-git
+pkgver=nightly.r4.gb0f4b37f
+pkgrel=1
+pkgdesc='A fast and minimalist 3D viewer - Draco Plugin'
+arch=('x86_64')
+url="https://github.com/$_name-app/$_name"
+license=('BSD')
+depends=('f3d-core' 'draco')
+makedepends=('git' 'git-lfs' 'cmake' 'nlohmann-json')
+source=("git+https://github.com/$_name-app/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_name/plugins/$_plugin/"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ cmake --build .
+}
+
+package() {
+ cd "$srcdir/$_name/plugins/$_plugin/build"
+ DESTDIR="$pkgdir" cmake --install .
+ DESTDIR="$pkgdir" cmake --install . --component configuration
+}