summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 797f7902b2d8..990062457899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# shellcheck disable=SC2034
_pkgname=fakepkg
pkgname="${_pkgname}-git"
-pkgver=1.42.0
+pkgver=v1.42.0
pkgrel=1
pkgdesc="Tool to reassemble installed packages from its deliverd files. It comes in handy if there is no internet connection available and you have no access to an up-to-date package cache"
arch=('any')
@@ -12,11 +12,16 @@ license=('AGPL3')
url="https://github.com/Edenhofer/fakepkg"
_url="https://gitlab.archlinux.org/tallero/${_pkgname}"
depends=('bash>=4.2' 'pacman' 'tar' 'gzip' 'sed' 'awk')
-makedepends=("git")
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+${_url}")
-sha512sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
package() {
cd "${srcdir}/${_pkgname}"