summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f6f27057f6c..898923b69782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=faustfilters
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
-pkgdesc="A collection of virtual-analog filter plugins"
-arch=('i686' 'x86_64')
+pkgdesc='A collection of virtual-analog filter plugins'
+arch=(x86_64)
url="https://github.com/SpotlightKid/${pkgname}"
-license=('MIT')
-depends=('gcc-libs')
-groups=('pro-audio' 'ladspa-plugins' 'lv2-plugins' 'vst-plugins')
-source=("https://github.com/SpotlightKid/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-source.tar.gz")
-md5sums=('008fc0b7913427d2c8dbbb4bf072af23')
+license=(MIT)
+depends=(glibc gcc-libs)
+groups=(pro-audio clap-plugins ladspa-plugins lv2-plugins vst-plugins vst3-plugins)
+source=("https://github.com/SpotlightKid/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver-source.tar.gz")
+sha256sums=('8dd653ec49a0c47de147236ca469578eb7002156b1633eef981104ad6a6eefd3')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
+ cd $pkgname-$pkgver
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" PREFIX=/usr install
# install documentation
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -vDm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname}
# install license file
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}