summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5292b0ac0aa8..05b3ae1a7b1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,32 @@ _TARGET_API=19
_pkgname=fb-adb
pkgname=$_pkgname-git
pkgver=20170602.r363.b931596
-pkgrel=5
+pkgrel=6
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
arch=('x86_64')
depends=('android-tools')
-makedepends=('git' 'vim' 'android-sdk-build-tools' "android-platform-$_TARGET_API" 'android-ndk')
+makedepends=('git' 'vim' 'android-sdk-build-tools' "android-platform-$_TARGET_API" 'android-ndk' 'python')
options=('!strip' '!buildflags')
-source=("git+$url.git")
-sha512sums=('SKIP')
+source=("git+$url.git"
+ 'no-file-offset-bits-64.patch')
+sha512sums=('SKIP'
+ '17379e48d9a881c2af33d01fa4df5c4969ebe89ffa442809c6215b517a3943b61d2a1b3e7675470282e41e758d464fa8e420b01c6060e3be57704e7469340b87')
pkgver() {
cd $_pkgname
printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $_pkgname
+
+ patch -Np1 -i ../no-file-offset-bits-64.patch
+
+ autoreconf -ifv
+}
+
build() {
# configure
cd $_pkgname