summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 683a1681ca79..83cbdf8f0ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
pkgname=fceux-git
-pkgver=e8c61d1b
+pkgver=2.2.3.1633.gf333a62d
pkgrel=1
pkgdesc="Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
arch=('i686' 'x86_64')
url="http://fceux.com/"
license=('GPL')
depends=('sdl' 'lua51' 'gtk2' 'gd' 'libgl')
-makedepends=('git' 'scons' 'libgl' 'glu')
+makedepends=('git' 'cmake' 'libgl' 'glu')
optdepends=('xchm: for viewing the help manual')
provides=('fceux')
conflicts=('fceux')
@@ -17,22 +17,23 @@ md5sums=('SKIP')
pkgver() {
cd fceux
- git describe --always| sed 's/-/./g'
+ git describe --always| sed 's/-/./g' | sed 's/fceux.//'
}
build() {
cd fceux
-
- scons RELEASE=1
+ mkdir -p build
+ cd build
+ cmake ../
+ make
}
package() {
cd fceux
- install -D -m755 bin/fceux "$pkgdir/usr/bin/fceux"
- install -D -m755 bin/fceux-net-server "$pkgdir/usr/bin/fceux-net-server"
- install -D -m644 bin/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
+ install -D -m755 build/src/fceux "$pkgdir/usr/bin/fceux"
+ install -D -m644 output/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
install -D -m644 "fceux.desktop" "$pkgdir/usr/share/applications/fceux.desktop"
install -D -m644 "fceux.png" "$pkgdir/usr/share/pixmaps/fceux.png"
}