summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD90
1 files changed, 50 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c94c8d0be21f..8c3e17dc8a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Masaki Haruka <yek at reasonset dot net>
-# Contributor: UTUMI Hirosi <utuhiro78 att yahoo dott co dott jp>
+# Contributor: UTUMI Hirosi <utuhiro78 at yahoo dot co dot jp>
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
## Mozc compile option
_bldtype=Release
-_mozcver=2.23.2815.102
-_fcitxver=2.23.2815.102.1
-_utdicdate=20200924
+_mozcver=2.25.4190.102
+_fcitxver=20201111
+_utdicdate=20201110
pkgver=${_mozcver}.${_utdicdate}
pkgrel=1
@@ -17,64 +17,74 @@ true && pkgname=('mozc-neologd-ut' 'fcitx-mozc-neologd-ut')
arch=('i686' 'x86_64')
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('custom')
-makedepends=('clang' 'gyp' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'zinnia' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
+makedepends=('clang' 'gyp' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
source=(
- http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_${_mozcver}+dfsg.orig.tar.xz
- protobuf-3.5.2.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.5.2.tar.gz
- https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/usage_dict.txt.patch
- https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Fix-build-with-gcc8.patch
- https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Change-from-python2-code-to-python3.patch
- https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/add_support_new_japanese_era.patch
- https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-${_fcitxver}.patch
+ https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozc-${_mozcver}.tar.bz2
+ abseil-cpp-20200923.2.tar.gz::https://github.com/abseil/abseil-cpp/archive/20200923.2.tar.gz
+ googletest-release-1.10.0.tar.gz::https://github.com/google/googletest/archive/release-1.10.0.tar.gz
+ japanese-usage-dictionary-master.zip::https://github.com/hiroyuki-komatsu/japanese-usage-dictionary/archive/master.zip
+ protobuf-3.13.0.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.13.0.tar.gz
+ https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-${_fcitxver}.patch
https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
- 'https://osdn.net/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F26%2F26671%2Fmozcdic-ut-neologd-20200924.1.tar.bz2'
+ https://www.post.japanpost.jp/zipcode/dl/kogaki/zip/ken_all.zip
+ https://www.post.japanpost.jp/zipcode/dl/jigyosyo/zip/jigyosyo.zip
+ 'https://osdn.net/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F26%2F26941%2Fmozcdic-ut-neologd-20201110.1.tar.bz2'
)
sha1sums=(
- '7e0a39ffd5ea68ecadb792fc521c16b5be1f25cb'
- 'd0c551031828ed9c07cc683762353a67b1a17627'
- 'c6f5aac79c7e98fbda96de251d8f0d0787344ca9'
- '4fe935b5c2d316119cf8957b6518b3b5e7bf6ecf'
- 'SKIP'
- '13f8fbbc768d5042fb55d877acf2a73fc8b5e3f0'
- '63a2b10e7d209c6216e2d912b2629efc44c637ea'
+ 'adf4968191ea1f9837b1f9d5d0aa47ac1e2ddee2'
+ '1dd3f0a937c3678437646d26ca6784bd6a9b2b26'
+ '9c89be7df9c5e8cb0bc20b3c4b39bf7e82686770'
+ 'bf15e8ff92cbde3c102cbf4ad50c2090a7165495'
+ '2160cfb354148da3fb3891b267c2edc7e3eb5c30'
+ '38de276494e299dc7e4816dfd95403fd0fdf8601'
'883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d'
'SKIP'
+ 'SKIP'
+ 'e15a4ab648bda5d754359bf555d3d3783515b165'
)
prepare() {
- cd mozc-${_mozcver}+dfsg
- mkdir -p src/third_party
- mv ${srcdir}/protobuf-3.5.2 src/third_party/protobuf
- patch -Np1 -i ${srcdir}/usage_dict.txt.patch
- patch -Np1 -i ${srcdir}/Fix-build-with-gcc8.patch
- patch -Np1 -i ${srcdir}/Change-from-python2-code-to-python3.patch
- patch -Np1 -i ${srcdir}/add_support_new_japanese_era.patch
+ cd mozc-${_mozcver}
+ rm -rf src/third_party
+ mkdir src/third_party
+ mv ${srcdir}/abseil-cpp-20200923.2 src/third_party/abseil-cpp
+ mv ${srcdir}/googletest-release-1.10.0 src/third_party/gtest
+ mv ${srcdir}/japanese-usage-dictionary-master src/third_party/japanese_usage_dictionary
+ mv ${srcdir}/protobuf-3.13.0 src/third_party/protobuf
patch -Np1 -i ${srcdir}/fcitx-mozc-${_fcitxver}.patch
- # Avoid fcitx5 build errors
- rm -rf src/unix/fcitx5/
+ # Add ZIP code
+ cd src/data/dictionary_oss/
+ PYTHONPATH="${PYTHONPATH}:../../" \
+ python ../../dictionary/gen_zip_code_seed.py \
+ --zip_code=${srcdir}/KEN_ALL.CSV --jigyosyo=${srcdir}/JIGYOSYO.CSV >> dictionary09.txt
+ cd -
+
+ # Avoid build errors
+ sed -i -e 's/-stdlib=libc++//' src/gyp/common.gypi
+ sed -i -e 's/-lc++//' src/gyp/common.gypi
# Add UT dictionary
- cat ${srcdir}/mozcdic-ut-neologd-${_utdicdate}.${pkgrel}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
+ cat ${srcdir}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
}
build() {
- cd mozc-${_mozcver}+dfsg/src
+ cd mozc-${_mozcver}/src
- _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool renderer/renderer.gyp:mozc_renderer unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n"
+ _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n"
- GYP_DEFINES="use_libzinnia=1 document_dir=/usr/share/licenses/mozc" python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
+ GYP_DEFINES="document_dir=/usr/share/licenses/mozc" python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
python build_mozc.py build -c $_bldtype $_targets
}
package_mozc-neologd-ut() {
- pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd Dictionary"
+ pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary."
arch=('i686' 'x86_64')
- depends=('qt5-base' 'zinnia')
- conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'mozc-ut-unified' 'fcitx-mozc-ut-unified')
- cd mozc-${_mozcver}+dfsg/src
+ depends=('qt5-base')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut+ut2' 'mozc-ut-unified' 'fcitx-mozc-ut-unified' 'mozc-ut-unified-full' 'fcitx-mozc-ut-unified-full')
+ cd mozc-${_mozcver}/src
install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
install -m 755 out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"
@@ -83,12 +93,12 @@ package_mozc-neologd-ut() {
}
package_fcitx-mozc-neologd-ut() {
- pkgdesc="Fcitx engine module for Mozc with NEologd Dictionary"
+ pkgdesc="Fcitx engine module for Mozc with NEologd UT dictionary."
arch=('i686' 'x86_64')
depends=("mozc-neologd-ut=${pkgver}" 'fcitx')
- replaces=('fcitx-mozc' 'fcitx-mozc-ut2' 'fcitx-mozc-ut' 'fcitx-mozc-ut-unified')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut+ut2' 'mozc-ut-unified' 'fcitx-mozc-ut-unified' 'mozc-ut-unified-full' 'fcitx-mozc-ut-unified-full')
- cd mozc-${_mozcver}+dfsg/src
+ cd mozc-${_mozcver}/src
for mofile in out_linux/${_bldtype}/gen/unix/fcitx/po/*.mo
do
filename=`basename $mofile`