summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 24 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6a2ab0ed5a3..51fd79cb6087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
pkgname=fcitx5-skin-adwaita-dark
-_pkgname=fcitx5-adwaita-dark
-pkgver=0.0.0.20200618
-_commit=8c1ed01b020672e26891cba4d9e426afef2b7436
+pkgver=r9.1d45848
pkgrel=1
pkgdesc="An Fcitx5 dark theme mimics GNOME Adwaita-dark"
-arch=('any')
+arch=(any)
+makedepends=(git)
url="https://github.com/escape0707/fcitx5-adwaita-dark"
license=('AGPL3')
-source=("https://github.com/escape0707/fcitx5-adwaita-dark/archive/$_commit/$_pkgname-$_commit.tar.gz")
-sha512sums=('62a2590a631bf8aa4531a59bd887c45e529fa50db5c7a79302b19d782ffe859e3bee26b9390face69d93cb4199e7b8a01fddbb08460fd310c549d3c9045466a9')
+makedepends=(git)
+source=("$pkgname::git+$url#commit=1d45848312368595f3eeb9c246f203ca7032cbdd")
+sha512sums=('SKIP')
-package() {
- _variant_name=adwaita-dark
- cd $_pkgname-$_commit
- install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/highlight.png
- install -Dm644 no_highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/no_highlight.png
- install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/panel.png
- install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/arrow.png
- install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/radio.png
- install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/theme.conf
+pkgver() {
+ cd "$pkgname"
+ # no tags then use number of revisions since beginning of the history
+ # https://wiki.archlinux.org/title/VCS_package_guidelines#The_pkgver()_function
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+package() {
+
+ cd $srcdir/$pkgname
+ install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/highlight.png
+ install -Dm644 no_highlight.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/no_highlight.png
+ install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/panel.png
+ install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/arrow.png
+ install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/radio.png
+ install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/theme.conf
+
#install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}