summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84a426208ecc..7b36384d7620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,26 @@ pkgrel=1
pkgdesc="A command-line tool to identify the file formats of digital objects."
arch=('any')
url="https://openpreservation.org/tools/fido/"
-license=('Apache')
-depends=(
- 'python-olefile'
- 'python-six'
- 'python-importlib_resources'
- 'python-requests')
-makedepends=(
- 'python-build'
- 'python-installer'
- 'python-pytest-runner'
- 'python-setuptools'
- 'python-wheel')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/openpreserve/fido/archive/v${pkgver}.tar.gz")
+license=('Apache-2.0')
+depends=('python'
+ 'python-olefile'
+ 'python-six'
+ 'python-importlib_resources'
+ 'python-requests')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-pytest-runner'
+ 'python-setuptools'
+ 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openpreserve/fido/archive/v$pkgver.tar.gz")
sha256sums=('6980d23cd7b5004b42334d3032adcbeafd99cf597edc758cad0cb23f2dbab18d')
build() {
- cd "${pkgname}-${pkgver}"
- python -m build --wheel --no-isolation
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${pkgname}-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}