summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6453743516e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alex Macleod <alex@macleod.io>
+pkgname=findpkg
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A fast command not found hook"
+arch=(any)
+url="https://github.com/Alexendoo/findpkg"
+license=(MIT)
+depends=(pacman)
+makedepends=(cargo)
+options=(emptydirs)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Alexendoo/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('0418c327b8211077b5fe9308bb434faa5a81d8f2f8a64032626f7404d5f310b3')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --target-dir target
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/findpkg "$pkgdir/usr/bin/findpkg"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/findpkg/LICENSE"
+ mkdir -pm755 "$pkgdir/var/lib/findpkg/"
+}