summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07dac1c04fd7..f803051d5960 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=firefox-tridactyl-git
-pkgver=1.17.0.r12.gcfc9b24a
+pkgver=1.21.1.r143.g5a11a97f
pkgrel=1
pkgdesc="Replace Firefox's control mechanism with one modelled on Vim"
url=https://github.com/tridactyl/tridactyl
arch=('any')
license=('Apache')
groups=('firefox-addons')
-makedepends=('git' 'node-gyp' 'python' 'yarn')
+makedepends=('git' 'node-gyp' 'python' 'strip-nondeterminism' 'yarn')
source=("git+$url.git")
sha512sums=('SKIP')
@@ -21,10 +21,13 @@ build() {
cd tridactyl
yarn install --frozen-lockfile --non-interactive
scripts/sign nosignbeta
+ strip-nondeterminism -t zip web-ext-artifacts/tridactyl-$pkgver.xpi
}
package() {
- install -Dm644 tridactyl/web-ext-artifacts/tridactyl_beta-${pkgver%%.r*}.xpi "$pkgdir"/usr/lib/firefox/browser/extensions/tridactyl.vim.betas@cmcaine.co.uk.xpi
+ cd tridactyl
+ install -Dm644 web-ext-artifacts/tridactyl_beta-${pkgver%%.r*}.xpi \
+ "$pkgdir"/usr/lib/firefox/browser/extensions/tridactyl.vim.betas@cmcaine.co.uk.xpi
}
# vim:set ts=2 sw=2 et: