summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 33 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 236ac17da282..087df83bb361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Alex Tharp <alex@toastercup.io>
-# Based on firestorm-bin PKGBUILD by: Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=firestorm-beta-bin
-pkgver=6.4.5.60799
+_appname=firestorm-beta
+pkgname="${_appname}-bin"
+pkgver=7.1.1.72630
pkgrel=1
-pkgdesc="Firestorm is a feature-packed third-party viewer for Second Life. This is the beta release that currently features the Environmental Enhancement Project (EEP)."
-url="https://www.firestormviewer.org/"
+pkgdesc="[ALPHA] Firestorm is a feature-packed third-party viewer for Second Life. This is the *alpha* release that currently features PBR support. **USE AT YOUR OWN RISK**"
+url="http://www.firestormviewer.org/"
license=('GPL')
arch=('x86_64')
-depends=(dbus-glib gconf glu gtk2 lib32-libidn lib32-libsndfile
- lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng
- libxss libxml2 mesa nss openal sdl vlc zlib)
+depends=(apr-util dbus-glib glu gtk2 lib32-libidn lib32-libsndfile
+ lib32-util-linux lib32-zlib libbsd libgl libidn libjpeg-turbo
+ libpng libxcrypt-compat libxss libxml2 mesa nss openal sdl
+ vlc zlib)
optdepends=(
'alsa-lib: for ALSA support'
'pepper-flash: for inworld Flash support'
@@ -21,19 +22,17 @@ optdepends=(
'mesa-libgl: For Intel, Radeon, Nouveau support'
'nvidia-libgl: for NVIDIA support'
'nvidia-utils: for NVIDIA support')
-conflicts=('firestorm' 'firestorm-bin' 'firestorm-nightly')
-install=firestorm.install
-source=("https://downloads.firestormviewer.org/linux/Phoenix_Firestorm-Betax64_x86_64_$pkgver.tar.xz"
- firestorm.desktop
- firestorm.launcher)
-md5sums=('a81c456113de1fd2ba4fb52671dded42'
- '6b22ac512adc9b226fd91a23f7fe9921'
- '2be5ef0f27414638a81003aa2f2ea6f1')
+install="${_appname}.install"
+tardir="Phoenix-Firestorm-Alphax64-${pkgver//./-}"
+source=("https://downloads.firestormviewer.org/test/linux/${tardir}.tar.xz"
+ "${_appname}.desktop"
+ "${_appname}.launcher")
+md5sums=('0051a964c93d0985aee532e87efb6f5c'
+ '7ff5bb5e5d5ff8f4a77656bac520c6d3'
+ 'a83a8c77f8619f06d23dd73b79e4703e')
prepare() {
- mv "$srcdir/Phoenix_Firestorm-Betax64_x86_64_$pkgver" "$srcdir/firestorm"
-
- cd "firestorm"
+ cd "${srcdir}/${tardir}"
for patch in ../*.patch; do
if [ ! -f "$patch" ]; then
break;
@@ -44,27 +43,24 @@ prepare() {
}
package() {
- cd "$srcdir/firestorm"
+ install -d "${pkgdir}/usr/lib"
+ cp -a "${srcdir}/${tardir}" "${pkgdir}/usr/lib/${_appname}"
+ cd "${pkgdir}/usr/lib/${_appname}"
- # File modes fix.
- find -type d -execdir chmod 755 "{}" \;
- find -type f -execdir chmod 644 "{}" \;
- chmod 755 bin/* firestorm etc/*
+ find app_settings skins -type f -execdir chmod 644 "{}" +
- # Install Desktop File
- install -D -m644 ../firestorm.desktop \
- "$pkgdir"/usr/share/applications/firestorm.desktop
+ # find and remove broken symlinks
+ find -L . -type l -delete
- # Install Icon File
- install -D -m644 firestorm_icon.png \
- "$pkgdir"/usr/share/pixmaps/firestorm_icon.png
+ # Install desktop file
+ install -D -m644 "${srcdir}/${_appname}.desktop" \
+ "$pkgdir/usr/share/applications/${_appname}.desktop"
- # Install Launcher
- install -D -m755 ../firestorm.launcher \
- "$pkgdir"/usr/bin/firestorm
+ # Install icon file
+ install -D -m644 firestorm_icon.png \
+ "$pkgdir/usr/share/pixmaps/${_appname}.png"
- # Move Data to Destination Directory
- cd ..
- install -d "$pkgdir"/opt
- mv firestorm/ "$pkgdir"/opt
+ # Install launcher
+ install -D -m755 "${srcdir}/${_appname}.launcher" \
+ "$pkgdir/usr/bin/${_appname}"
}