summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c11b92bbb50d..8cbe47d590ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=flashmq-git
-pkgver=0.9.6.r1.g3746e3d
+pkgver=1.0.2.r0.g3b5a3d5
pkgrel=1
pkgdesc="FlashMQ is a light-weight MQTT broker/server, designed to take good advantage of multi-CPU environments"
arch=('any')
@@ -9,13 +9,13 @@ url="https://github.com/halfgaar/FlashMQ"
license=('MIT')
provides=(${pkgname})
conflicts=(${pkgname} ${pkgname%-git})
-#replaces=(${pkgname})
+replaces=()
depends=()
-makedepends=('git' 'cmake' 'ninja')
+makedepends=(git cmake ninja sed docbook2x libxslt)
backup=()
options=('!strip')
-#install=${pkgname}.install
-source=("${pkgname%-git}::git+https://ghproxy.com/${url}.git")
+install=
+source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -25,8 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}/"
- cmake -B build -G Ninja
+ sed --in-place 's#DESTINATION "/lib#DESTINATION "/usr/lib#' CMakeLists.txt
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -G Ninja
+
ninja -C build
+
+ cd man
+ sed -i 's#docbook2x-man#db2x_docbook2man#g' Makefile
+ make -j
}
package() {