summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d655d93d324..1a48500626cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=fluidsynth-git
-pkgver=1.1.6.r423.048c51c
+pkgver=1.1.8.r868.e485129
pkgrel=1
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications (development version)"
arch=('i686' 'x86_64')
@@ -12,11 +12,11 @@ makedepends=('git' 'cmake')
optdepends=('pulseaudio: PulseAudio sound support')
conflicts=('fluidsynth')
provides=("fluidsynth=${pkgver%.r*}")
-source=(${pkgname%-*}::"git+http://git.code.sf.net/p/fluidsynth/code-git")
+source=(${pkgname%-*}::"git+https://github.com/FluidSynth/fluidsynth.git")
md5sums=('SKIP')
pkgver() {
- cd ${pkgname%-*}/${pkgname%-*}
+ cd ${pkgname%-*}
_major=$(grep -o "FLUIDSYNTH_VERSION_MAJOR.*" CMakeLists.txt | grep -o "[0-9]*")
_minor=$(grep -o "FLUIDSYNTH_VERSION_MINOR.*" CMakeLists.txt | grep -o "[0-9]*")
@@ -26,16 +26,21 @@ pkgver() {
printf "$_major.$_minor.$_micro.r%s.%s" "$_rev" "$_hash"
}
+prepare() {
+ rm -rf build
+ mkdir build
+}
+
build() {
- cd ${pkgname%-*}
+ cd build
- cmake ${pkgname%-*} -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -Denable-ladspa=ON \
- -DLIB_SUFFIX=""
+ cmake ../${pkgname%-*} -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -Denable-ladspa=ON \
+ -DLIB_SUFFIX=""
make
}
package() {
- make -C ${pkgname%-*} DESTDIR="$pkgdir/" install
+ make -C build DESTDIR="$pkgdir/" install
}