summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a9758c45ea7..671cb3e33682 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=fnm
-pkgver=1.35.0
+pkgver=1.35.1
pkgrel=1
pkgdesc="Fast and simple Node.js version manager, built with Rust"
arch=('x86_64')
@@ -9,15 +9,10 @@ license=('GPL3')
depends=('xz' 'bzip2' 'gcc-libs')
makedepends=('cargo')
conflicts=('fnm-bin')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz" "completions-panic.patch::$url/pull/1010/commits/a1f9f14a0ab7221b52ed2f563e50aa7b5a7e842e.patch")
-sha256sums=('31b29e4534f17240ae576c9b726498bf551f1c14b3a0fb3ecc9f4aa95843d27a' '573e43881b65ff64a6b2fb569c10cc447c80a42da8e05ae7867e5b42c3d9db57')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('df0f010f20e6072a8a52365f195cc94c35ebaf486cc285948e10eabf768d17ba')
options=('!lto')
-prepare() {
- cd "$pkgname-$pkgver"
- patch --strip=1 --input=$srcdir/completions-panic.patch
-}
-
build() {
cd "$pkgname-$pkgver"
CARGO_TARGET_DIR=target cargo build --release --locked