summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a09b3614ec95..58c4db2aae49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@ pkgname=fontastic-bin
_pkgname=Fontastic
pkgver=0.2.0
_electronversion=25
-pkgrel=3
+pkgrel=4
pkgdesc="A stunning font management and cataloging application."
arch=('x86_64')
url="https://github.com/tomshaw/fontastic"
license=('MIT')
conflits=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}-bin"
+ "electron${_electronversion}"
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-amd64.deb"
@@ -19,11 +19,12 @@ source=(
)
sha256sums=('3b34a974d7da78f9621b02e11a35c00d9f81a19ec42ed1dddfc4f4d59d67d962'
'd461d5796257402081b89cae64365068a66d193696f7c64cb7e6fd307b4a48d9'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@cfgdirname@|${pkgname%-bin}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*