summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f63823122bc..abe03c5f40d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,40 +8,26 @@
# Contributor: gborzi
pkgname=freecad
-_pkgver=0.17
-_count=13544
-_commit=e1db7bff8ff36439373eb9a426567d8afe289c4d
+_pkgver=0.18
+_count=16093
+_commit=690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
pkgver=$_pkgver.$_count
-pkgrel=9
+pkgrel=1
pkgdesc='A general purpose 3D CAD modeler'
arch=('x86_64')
url='https://www.freecadweb.org/'
license=('LGPL')
depends=('boost-libs' 'curl' 'opencascade>=7.2' 'xerces-c' 'libspnav' 'glu' 'netcdf'
'shared-mime-info' 'hicolor-icon-theme' 'jsoncpp' 'qt5-base' 'qt5-declarative' 'qt5-svg' 'qt5-tools'
- 'qt5-webkit' 'med' 'python2-pivy' 'python2-pyside2' 'python2-matplotlib' 'pyside2-tools')
+ 'qt5-webkit' 'med' 'python-pivy' 'python-pyside2' 'python-matplotlib' 'pyside2-tools')
makedepends=('boost' 'eigen' 'gcc-fortran' 'swig' 'xerces-c' 'desktop-file-utils' 'git'
- 'cmake' 'coin>=3.1.3-9' 'python2-shiboken2' 'pyside2' 'shiboken2')
-optdepends=('python2-matplotlib' 'python2-pyqt5' 'graphviz' 'openscad')
+ 'cmake' 'coin>=4.0.0a' 'python-shiboken2' 'pyside2' 'shiboken2')
+optdepends=('python-matplotlib' 'graphviz' 'openscad')
source=("git+https://github.com/FreeCAD/FreeCAD.git#commit=$_commit"
- "${pkgname}.desktop" "${pkgname}.xml"
- 'gcc8.patch' 'smesh-pthread.patch' 'qt5.11.patch' 'boost1.69.patch')
+ "${pkgname}.desktop" "${pkgname}.xml")
sha256sums=('SKIP'
'617968d7bbd1da71bdedaed1b66c5d6eaf24e0fb34678b93f5d925d370c66296'
- '248918de7d3c2145b5cc4fbbc9e224d22f4a6ca7ead2680e8c3a32e91772482a'
- '618bb85c4f3a4eb0e329d1fc30391b777c9b0cffe97aa1e96d45f58b18424311'
- '170c90ee6ef64cf3c8e6a35ca94bb1187d346707f7e0779022e614563c6b74f6'
- 'a639c9d51f8443e4d2270fe60d5ac3ac62c7c64c532620108514840f8e8704bc'
- '53d5ec0b5337010671ed291dd007dd0f73db61b7313c1edbca105e5bc4921021')
-
-prepare() {
- cd "${srcdir}/FreeCAD"
-
- patch -Np1 -i ../gcc8.patch
- patch -Np1 -i ../smesh-pthread.patch
- patch -Np1 -i ../qt5.11.patch
- patch -Np1 -i ../boost1.69.patch
-}
+ '1d98fa4e62f352966eb357c93f54b1f0bf562931e8323bf70a83b5e221a5fb14')
build() {
cd "${srcdir}/FreeCAD"
@@ -54,7 +40,7 @@ build() {
-DFREECAD_USE_EXTERNAL_PIVY=ON \
-DFREECAD_USE_QT_FILEDIALOG=ON \
-DBUILD_QT5=ON \
- -DPYTHON_EXECUTABLE=/usr/bin/python2
+ -DPYTHON_EXECUTABLE=/usr/bin/python
make
}