summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 4 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce85f59f1967..423f46441735 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_hgname=gsm-codec-lib
_pkgname=freecalypso-gsm-codec-lib
pkgname="${_pkgname}-hg"
-pkgver=r251.946849291027
-pkgrel=2
+pkgver=r488.6724fbb01a09
+pkgrel=1
pkgdesc="FreeCalypso GSM codec libraries and utilities"
arch=('x86_64' 'i686')
url="https://www.freecalypso.org/hg/${_hgname}"
license=('custom')
groups=('freecalypso')
-depends=('gsm')
makedepends=('mercurial')
source=("hg+https://www.freecalypso.org/hg/${_hgname}")
md5sums=('SKIP')
@@ -20,14 +19,9 @@ pkgver() {
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
-prepare() {
- cd "${_hgname}"
- files=$(hg grep -l "#include <gsm.h>")
- sed -i "s#include <gsm.h>#include <gsm/gsm.h>#" $files
-}
-
build() {
cd "${_hgname}"
+ ./configure --prefix="/usr" CFLAGS="-std=gnu89 ${CFLAGS}"
make
}
@@ -38,14 +32,5 @@ package() {
install -d "${pkgdir}/usr/share/doc/${_pkgname}"
cp -r doc/* "${pkgdir}/usr/share/doc/${_pkgname}/"
- # DESTDIR is not respected, use INSTALL_PREFIX and INSTBIN instead
- make INSTALL_PREFIX="${pkgdir}/usr" install-lib
- make INSTBIN="${pkgdir}/opt/freecalypso/bin" install-utils
-
- # For the sake of consistency with the 'gsm' package, move all header files
- # to '/usr/include/gsm'. This problem was discussed here:
- # https://www.freecalypso.org/pipermail/community/2023-September/000892.html
- # https://www.freecalypso.org/pipermail/community/2023-September/000895.html
- install -d "${pkgdir}/usr/include/gsm"
- mv ${pkgdir}/usr/include/*.h "${pkgdir}/usr/include/gsm/"
+ make DESTDIR=$pkgdir install
}