summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 31 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44ac77e9f2f0..d7cc2d0949a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,55 @@
# Contributor: Slash <demodevil5[at]yahoo[dot]com>
pkgname=fuhquake
-pkgver=0.31
+pkgver=0.31
pkgrel=4
pkgdesc="A QuakeWorld Client for Win32/Linux. You need the retail pak files to play."
url="http://www.fuhquake.net/"
-license="GPL"
+license=('GPL')
depends=('libgl')
+arch=('i686')
makedepends=('unzip')
conflicts=('ezquake')
provides=()
install=fuhquake.install
source=('fuhquake.launcher' 'fuhquake.install' 'fuhquake.desktop' 'fuhquake.ico' \
"http://www.slashbunny.com/quake/$pkgname-linux-v$pkgver.zip")
-md5sums=('c471e673a64882e3653fd953b1a3da1f' '8ea170b09fe50223bb66bf93a3f160b0'\
- 'e64a0918e48595f4a8fb47d0e39b8c84' '6a0f7982f82886210448490be5762ab0'\
+md5sums=('c471e673a64882e3653fd953b1a3da1f'
+ 'f66f7cccd41f64955e3993c32e80191f'
+ 'e64a0918e48595f4a8fb47d0e39b8c84'
+ '6a0f7982f82886210448490be5762ab0'
'd4476cc49db638e5304ddd6cd744b62a')
build() {
- cd $startdir/src
+ cd $srcdir
- # Unpack fuhQuake
- unzip $pkgname-linux-v$pkgver.zip -d quake/
+ # Unpack fuhQuake
+ unzip $pkgname-linux-v$pkgver.zip -d quake/
- # Make binaries executable
- chmod +x quake/fuhquake-gl.glx
- chmod +x quake/fuhquake.svga
- chmod +x quake/fuhquake.x11
+ # Make binaries executable
+ chmod +x quake/fuhquake-gl.glx
+ chmod +x quake/fuhquake.svga
+ chmod +x quake/fuhquake.x11
- # Move data to package directory
- install -d $startdir/pkg/opt/
- mv quake/ $startdir/pkg/opt/
+ # Move data to package directory
+ install -d $pkgdir/opt/
+ mv quake/ $pkgdir/opt/
- # Make id1 Directory for pak0.pak and pak1.pak files
- install -d $startdir/pkg/opt/quake/id1/
+ # Make id1 Directory for pak0.pak and pak1.pak files
+ install -d $pkgdir/opt/quake/id1/
- # Install Launcher
- install -D -m755 $startdir/src/fuhquake.launcher \
- $startdir/pkg/usr/bin/fuhquake
+ # Install Launcher
+ install -D -m755 $srcdir/fuhquake.launcher \
+ $pkgdir/usr/bin/fuhquake
- # Install Desktop
- install -D -m644 $startdir/src/fuhquake.desktop \
- $startdir/pkg/usr/share/applications/fuhquake.desktop
+ # Install Desktop
+ install -D -m644 $srcdir/fuhquake.desktop \
+ $pkgdir/usr/share/applications/fuhquake.desktop
- # Install Icon
- install -D -m644 $startdir/src/fuhquake.ico \
- $startdir/pkg/usr/share/pixmaps/fuhquake.ico
+ # Install Icon
+ install -D -m644 $srcdir/fuhquake.ico \
+ $pkgdir/usr/share/pixmaps/fuhquake.ico
- # Make Configs directory with permissions root:games so users can save configs
- install -d -m 775 -o root -g games $startdir/pkg/opt/quake/fuhquake/configs/
-}
+ # Make Configs directory with permissions root:games so users can save configs
+ install -d -m 775 -o root -g games $pkgdir/opt/quake/fuhquake/configs/
+}