summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15639c7cf202..de079f65e631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: nubz4lif <nubz4lif at proton dot me>
pkgname=funkin-quack-git
-pkgver=0.1.r69.gb733f72
-pkgrel=3
+pkgver=0.2.r295.g371c310
+pkgrel=2
pkgdesc="A modification for Friday Night Funkin': Psych Engine to provide better linux support and more features."
arch=("x86_64" "i686" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
license=("Apache")
@@ -13,8 +13,8 @@ conflicts=("funkin")
sha256sums=("SKIP"
"8cb8c993a70609663b1dca92f8139ee06573828aee8cbc8b9a7d84aa4f7e74b0"
"c0ce512b409a5c01b696c5434c796dfc2a30bfb68b3aab352573b1072a16c9ce")
-source=("Funkin::git+https://github.com/Noobz4Life/FNF-QuackEngine.git"
- "funkin.desktop"
+source=("Funkin::git+https://github.com/Noobz4Life/FNF-QuackEngine.git#branch=psych-update"
+ "funkin.desktop"
"funkin.sh")
pkgver() {
@@ -24,20 +24,19 @@ pkgver() {
build() {
cd "${srcdir}/Funkin"
+ haxelib deleterepo # obviously not ideal, but essentially makes sure that no prompts about overwriting a version with another happens
haxelib newrepo
- haxelib install hmm
- haxelib install lime
- haxelib git hxCodec https://github.com/polybiusproxy/hxCodec.git
- haxelib run hmm install
+ echo 'oy9:showMacroty8:loopCosti25y10:includeAllfg' >> ~/settings.cocoa #skips sscript setup mode
+
+ haxelib install hxcpp > /dev/null --quiet
+ haxe -cp ./setup -D analyzer-optimize -main Main --interp
echo n | haxelib run lime setup
pushd "${srcdir}/Funkin" > /dev/null
- for _ in 1 2; do # Run this twice due to SScript setup mode, Haxe doesn't recompile unchanged files anyway.
- #echo n due to SScript asking if you want to customize settings.
- echo n | haxelib run lime build linux -final -D officialBuild -D useAppStorage
- done
+ haxelib run lime build linux -final -D officialBuild -D useAppStorage
+
popd > /dev/null
}
@@ -54,4 +53,7 @@ package() {
install -Dm0755 funkin.sh "${pkgdir}/usr/bin/funkin"
install -Dm0644 funkin.desktop "${pkgdir}/usr/share/applications/funkin.desktop"
+
+ touch "${pkgdir}/usr/share/funkin/modsList.txt"
+ chmod 666 "${pkgdir}/usr/share/funkin/modsList.txt"
}