summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91055f8c28b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
+
+pkgname=fwupdate
+pkgver=0.4
+pkgrel=1
+pkgdesc='Tools for using the ESRT and UpdateCapsule() to apply firmware updates'
+arch=('i686' 'x86_64')
+url='https://github.com/rhinstaller/fwupdate'
+license=('GPL2')
+depends=('efivar')
+makedepends=('pesign')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('83ec7b2bf8d3bc37c6a60044d964503233c359150bcdb6f30e9f01ef1edd97dd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make GNUEFIDIR=/usr/lib
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make LIBDIR=/usr/lib DESTDIR="${pkgdir}" install
+
+ #don't install into /boot. copy files to /usr/lib/fwupdate for manual installation
+ install -d ${pkgdir}/usr/lib/fwupdate
+ mv ${pkgdir}/boot/efi/EFI ${pkgdir}/usr/lib/fwupdate/EFI
+ rm -rf ${pkgdir}/boot
+}