summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa51c5fafe9a..1c568a8d4cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=game-of-life
-pkgver=0.3.0
+pkgver=0.3.2
pkgrel=1
pkgdesc="A simulator of Conway's game of life"
arch=('x86_64' 'aarch64')
@@ -11,13 +11,20 @@ depends=('libadwaita')
makedepends=('meson' 'cargo')
checkdepends=('appstream-glib')
source=($pkgname-$pkgver.tar.gz::$url/archive/v${pkgver//_/-}.tar.gz)
-b2sums=('82c37ef178ad8f8eb664426acc353fe5fdce46a2d60753fd15455cc761599a2a3a1c27dafbadea0bf56842776ba198f0bda0eba78db5694e9a5b2e23a5326530')
+b2sums=('ce0e2b8951c6d169c3e18bdfb465a7bdc6c841b52301379d85f9db24b786f3cca841990809fa55e191cd68342e570bb27cc55cb045c53ab70ee1f8b5cd9fb5c8')
+
+prepare() {
+ cd "$pkgname-${pkgver//_/-}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
local meson_options=(
--buildtype release
)
+ export RUSTUP_TOOLCHAIN=stable
arch-meson "$pkgname-${pkgver//_/-}" build "${meson_options[@]}"
meson compile -C build
}