summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fb9ad8251ac..26c9148d5414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,22 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
pkgname=geary-git
-pkgver=r5007.f4b35869
+pkgver=r5013.b153755d
pkgrel=1
pkgdesc="An email application built around conversations, for the GNOME 3 desktop."
arch=(i686 x86_64)
url="https://gitlab.gnome.org/GNOME/geary"
license=('GPL3')
depends=('appstream-glib' 'enchant' 'folks' 'gcr' 'gmime' 'gtk3'
- 'gnome-online-accounts' 'gspell' 'libgee' 'libnotify' 'libsoup'
- 'libunwind' 'libxml2' 'libytnef' 'sqlite' 'webkit2gtk')
+ 'gnome-online-accounts' 'gspell' 'libgee' 'libhandy' 'libnotify'
+ 'libsoup' 'libunwind' 'libxml2' 'libytnef' 'sqlite' 'webkit2gtk')
makedepends=('git' 'itstool' 'meson' 'vala')
provides=('geary')
conflicts=('geary')
-source=('git+https://gitlab.gnome.org/GNOME/geary.git')
-sha256sums=('SKIP')
+source=('git+https://gitlab.gnome.org/GNOME/geary.git'
+ 'force-system-libhandy.patch')
+sha256sums=('SKIP'
+ '3817bad616f8187c45d47101b62f2dcc5172717dfbf91892e81d88905e2406cf')
pkgver() {
cd "$srcdir/geary"
@@ -25,10 +27,9 @@ pkgver() {
}
prepare() {
- cd "$srcdir/geary"
- if [[ -d build ]]; then
- rm -rf build
- fi
+ cd "$srcdir/geary"
+ rm -rf build
+ patch -Np1 -i ../force-system-libhandy.patch
}
build() {