summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcbb11b76492..89cc95de35de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Michal Bozon <bozonm@vscht.cz>
+
pkgname=geekcode
pkgver=1.7.3
pkgrel=1
pkgdesc="Classic self-classification code generator"
-arch=('i686') # at least
-url="http://www.geekcode.com"
+arch=('i686' 'x86_64')
+url="http://www.geekcode.com/"
license=('GPL')
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
md5sums=('b794916a8875f71f1442f6e70432d6de')
build() {
- cd $startdir/src/$pkgname-$pkgver
- make || return 1
- # Makefile install has fixed /usr/local/bin/geekcode path set
- # so install it ourselves
- install -D -m 755 geekcode $startdir/pkg/usr/bin/geekcode
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ install -Dm755 $pkgname "${pkgdir}"/usr/bin/$pkgname
}