summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce1a5e1ec1ed..3330c4c4beed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=geophar
pkgver=15.10.2
pkgrel=1
pkgdesc="The swiss-knife of math teachers. Simple tool to produce beautiful mathematical pictures."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://wxgeo.free.fr/"
license=('GPL2')
depends=('python2-qscintilla')
@@ -19,5 +19,6 @@ package() {
chmod a+w $pkgdir/opt/geophar/config
# Forces usage of python2
- sed -i 's,/usr/bin/env python$,/usr/bin/env python2,' $pkgdir/opt/geophar/geophar.pyw
+ sed -i 's,#!/usr/bin/env python$,#!/usr/bin/env python2,' $pkgdir/opt/geophar/geophar.pyw `grep -rlI "^#!/usr/bin/env python$" $pkgdir/opt/geophar`
+ sed -i 's,#!/usr/bin/python$,#!/usr/bin/python2,' `grep -rlI "#!/usr/bin/python$" $pkgdir/opt/geophar`
}