summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cb1bba7397c..0de283e8f076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ghdl-mcode-git
pkgver=2.0.0dev.r6945.gaee3585af
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'pentium4')
pkgdesc='VHDL simulator - mcode back-end'
url='https://github.com/ghdl/ghdl'
@@ -45,6 +45,10 @@ pkgver() {
build() {
cd "${srcdir}/ghdl"
+ export ADA_FLAGS="$CFLAGS -fno-strict-aliasing"
+ ADA_FLAGS="${ADA_FLAGS//-Wformat}"
+ ADA_FLAGS="${ADA_FLAGS//-Werror=format-security}"
+
./configure \
--prefix=/usr/ \
--enable-libghdl \