summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b2ff4b668ac..3b0255f7a7df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Tommy Jerry Mairo <tjm@member.fsf.org>
pkgname=ghidra-fidb-repo
pkgver=20200530
-pkgrel=2
+pkgrel=4
pkgdesc="Ghidra Function ID dataset repository"
arch=("any")
url="https://github.com/threatrack/ghidra-fidb-repo"
license=('MIT')
optdepends=("ghidra")
-source=("https://github.com/threatrack/$pkgname/releases/download/$pkgver/$pkgname""_""$pkgver.zip")
-sha256sums=("cbaae947dc41edfd16bcb787f0c9bde4b938b31225a4dad0ee9d254f9360799d")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/threatrack/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=("fa8987b329232de6d03fc79d85cd2ab48933ca791e73b582ca041f6567ff2932")
package() {
- mkdir -p "$pkgdir/opt/ghidra/Ghidra/Features/FunctionID/data/"
- cd "$pkgdir/opt/ghidra/Ghidra/Features/FunctionID/data/"
- cp "$srcdir/$pkgname""_""$pkgver.zip" "$pkgdir/opt/ghidra/Ghidra/Features/FunctionID/data/"
+ mkdir -p "$pkgdir/opt/ghidra/Ghidra/Features/FunctionID/data/$pkgname"
+ cd
+ find "$srcdir/$pkgname-$pkgver" -type f -name '*.fidb' -exec \
+ install -m 444 {} "$pkgdir/opt/ghidra/Ghidra/Features/FunctionID/data/$pkgname" \;
}