summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f967432fdaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: M. Mastroeni <the_maxtro@hotmail.it>
+pkgname=gimp-gap
+pkgver=2.6.0
+pkgrel=2
+pkgdesc="Gimp Animation Package, gimp's plugin for animation"
+url="https://www.gimp.org/tutorials/Using_GAP/"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=('gimp>=2.6.0' 'glib2')
+optdepends=('libxvid: compression codec'
+ 'libbz2: data compressor'
+ 'faac: audio encoder'
+ 'faad: audio decoder'
+ 'libmp3lame: mpeg layer 3 codec'
+ 'libx264: H264 codec')
+source=("http://download.gimp.org/pub/gimp/plug-ins/v2.6/gap/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('249ed829de8b78675c0fe4ef4212089f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure CC="gcc" CXX="g++" LDFLAGS=-lm
+ cmake
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}