summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ce730e57984..d6237a232570 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,38 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=gimp-lensfun
-pkgver=0.2.4
+# commit from gimp-2.10 branch
+_commit='1c5a5c1534b5faf098b7441f8840d22835592f17'
+pkgver=0.2.4+9+gc5eaf97
pkgrel=1
-pkgdesc="A Gimp plugin to correct lens distortion using the lensfun library and database."
+pkgdesc='A Gimp plugin to correct lens distortion using the lensfun library and database'
arch=('i686' 'x86_64')
-url="http://seebk.github.io/GIMP-Lensfun/"
+url='http://seebk.github.io/GIMP-Lensfun/'
license=('GPL')
depends=('gimp' 'lensfun' 'exiv2')
-source=("https://github.com/seebk/GIMP-Lensfun/releases/download/${pkgver}/gimplensfun-${pkgver}.tar.gz")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/seebk/GIMP-Lensfun/archive/${pkgver}.tar.gz")
-sha256sums=('7a4e6dade910952cdb9afc62f34e286d230dd73c3a1630415c106b5260eb94de')
+makedepends=('git')
+source=("git+https://github.com/seebk/GIMP-Lensfun.git?commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/GIMP-Lensfun
+
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- cd ${srcdir}/GIMP-Lensfun-${pkgver}
+ cd ${srcdir}/GIMP-Lensfun
- make
+ make
}
package() {
- cd ${srcdir}/GIMP-Lensfun-${pkgver}
+ cd ${srcdir}/GIMP-Lensfun
- install -D -m0755 gimp-lensfun ${pkgdir}/usr/lib/gimp/2.0/plug-ins/gimp-lensfun
+ install -D -m0755 gimp-lensfun ${pkgdir}/usr/lib/gimp/2.0/plug-ins/gimp-lensfun
- install -D -m0644 CHANGES.txt ${pkgdir}/usr/share/doc/gimp-lensfun/CHANGES.txt
- install -D -m0644 LICENSE.txt ${pkgdir}/usr/share/doc/gimp-lensfun/LICENSE.txt
- install -D -m0644 README.txt ${pkgdir}/usr/share/doc/gimp-lensfun/README.txt
+ install -D -m0644 CHANGES.txt ${pkgdir}/usr/share/doc/gimp-lensfun/CHANGES.txt
+ install -D -m0644 LICENSE.txt ${pkgdir}/usr/share/doc/gimp-lensfun/LICENSE.txt
+ install -D -m0644 README.txt ${pkgdir}/usr/share/doc/gimp-lensfun/README.txt
}