summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 658faa52a143..3e5f4aa6fee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=girens-git
-pkgver=1.1.9.r3.gd3d27c2
+pkgver=1.1.10.r14.g448e92d
pkgrel=1
pkgdesc="Girens is a Plex GTK client for playing movies, TV shows and music from your Plex library"
arch=('x86_64')
url="https://gitlab.gnome.org/tijder/girens"
license=('GPL3')
-depends=('mpv' 'plex-remote' 'python-plexapi' 'libass' 'libhandy' 'fribidi' 'ffmpeg' 'python-mpv' 'python-idna' 'python-certifi' 'python-chardet' 'python-urllib3' 'python-requests' 'python-tqdm' 'python-six' 'python-websocket-client')
-makedepends=('git' 'meson' 'python')
+depends=('libadwaita' 'org.freedesktop.secrets' 'mpv' 'plex-remote-git' 'python-plexapi' 'libass' 'python-opengl' 'python-mpv' 'fribidi' 'ffmpeg' 'python-mpv' 'python-idna' 'python-certifi' 'python-chardet' 'python-urllib3' 'python-requests' 'python-tqdm' 'python-six' 'python-websocket-client')
+makedepends=('git' 'blueprint-compiler' 'meson')
checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+$url.git)
-sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -21,14 +21,18 @@ pkgver() {
}
build() {
- arch-meson ${pkgname%-git} build
+ local meson_options=(
+ --libdir=lib
+ )
+
+ arch-meson "${pkgname%-git}" build "${meson_options[@]}"
meson compile -C build
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs || :
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}