summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 10 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f5a05bfbe23..7d3148772d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
pkgname=git-subrepo
pkgver=0.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="Git submodule alternative"
arch=(any)
url="https://github.com/ingydotnet/$pkgname"
license=(MIT)
-depends=(bash git)
+depends=(bash 'bashplus=0.1.0' git)
checkdepends=(perl)
-backup=("etc/profile.d/$pkgname.sh")
-source=("git+$url.git#commit=110b9eb13f259986fffcf11e8fb187b8cce50921")
-b2sums=('SKIP')
+source=("git+$url.git#commit=110b9eb13f259986fffcf11e8fb187b8cce50921"
+0001-hardcode-path-to-bashplus.patch)
+b2sums=('SKIP'
+ 'b8ec76eaf76802cd000d757e17cf48da582d28f27a992b0e98503c400b615dc4875db8477a388600ee8eb547d188d75d79312d2c697b992a780009f1b103ffbb')
prepare() {
cd $pkgname
+ patch -Np1 -i ../0001-hardcode-path-to-bashplus.patch
+
# remove flaky tests
rm -rf test/{push-force,status}.t
}
@@ -26,20 +29,9 @@ check() {
package() {
cd $pkgname
- install -vdm755 "$pkgdir/opt/"
- cp -R . "$pkgdir/opt/$pkgname"
- rm -rf "$pkgdir/opt/$pkgname/"{.git{,attributes,ignore},ext/test-more-bash,man,test}
-
- install -vdm755 "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sf "/opt/$pkgname/License" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
+ install -vDm644 License "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -vDm644 man/man1/$pkgname.1 -t "$pkgdir/usr/share/man/man1/"
- install -vDm755 /dev/stdin "$pkgdir/etc/profile.d/$pkgname.sh" <<eof
-source /opt/git-subrepo/.rc
-eof
-
- #make DESTDIR="$pkgdir" PREFIX="/usr" install
- #install -vDm755 lib/$pkgname -t "$pkgdir/usr/bin/"
+ install -vDm755 lib/$pkgname -t "$pkgdir/usr/bin/"
install -vDm644 share/completion.bash "$pkgdir/usr/share/bash-completion/completions/$pkgname"
install -vDm644 share/zsh-completion/_$pkgname -t "$pkgdir/usr/share/zsh/site-functions/"
}