summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 090ea8d9e7c7..c19edd256734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgbase=glib2-selinux
pkgname=(glib2-selinux glib2-selinux-docs)
-pkgver=2.78.1
+pkgver=2.79.1
pkgrel=1
pkgdesc="Low level core library"
url="https://wiki.gnome.org/Projects/GLib"
-license=(LGPL)
+license=(LGPL-2.1-or-later)
arch=(x86_64)
depends=(pcre libffi util-linux-libs zlib libsysprof-capture)
makedepends=(dbus gettext gtk-doc shared-mime-info python libelf git util-linux
@@ -17,17 +17,17 @@ options=(
debug
staticlibs
)
-_commit=21624e78f013ee8706483086e3086076d08fe242 # tags/2.78.1^0
+_commit=143cb92c350bd1cb5411570600b8db2408c9d61d # tags/2.79.1^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/gvdb.git"
noisy-glib-compile-schemas.diff
glib-compile-schemas.hook gio-querymodules.hook
)
sha256sums=('SKIP'
+ 'SKIP'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
- '2a9f9b8235f48e3b7d0f6cfcbc76cd2116c45f28692cac4bd61074c495bd5eb7'
- '92d08db5aa30bda276bc3d718e7ff9dd01dc40dcab45b359182dcc290054e24e')
+ 'fbf49aef4b48f22c1abf40892e2e80b66409f83bd4a3ea155cd811b0c9c1e3b9')
pkgver() {
cd glib
@@ -50,9 +50,10 @@ build() {
CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
local meson_options=(
--default-library both
+ -D documentation=true
-D glib_debug=disabled
- -D gtk_doc=true
- -D man=true
+ -D gtk_doc=enabled
+ -D man-pages=enabled
-D selinux=enabled
-D sysprof=enabled
)