summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4eb6b98981c6..e7895c4fa944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=glog-git
-pkgver=0.6.0.r27.g6742834
+pkgver=0.7.0.r4.gea0748d
pkgrel=1
pkgdesc="C++ implementation of the Google logging module"
arch=('i686' 'x86_64')
url="https://github.com/google/glog"
-license=('BSD')
-makedepends=('git')
+license=('BSD-3-Clause')
+depends=('gcc-libs' 'gflags')
+makedepends=('git' 'cmake')
provides=("google-glog=$pkgver")
conflicts=('google-glog')
-options=('staticlibs')
source=('git+https://github.com/google/glog.git')
sha256sums=('SKIP')
@@ -18,28 +18,35 @@ sha256sums=('SKIP')
pkgver() {
cd "glog"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
cd "glog"
- ./autogen.sh
- ./configure \
- --prefix="/usr"
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DWITH_PKGCONFIG=ON \
+ ./
+ make -C "_build"
}
check() {
cd "glog"
- #make check
+ #make -C "_build" test
}
package() {
cd "glog"
- make DESTDIR="$pkgdir" install
+ make -C "_build" DESTDIR="$pkgdir" install
install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/glog"
}