summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 8 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2f175bbc97b..50372b6e0262 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,19 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Contributor: abenson <adrian.m.benson@gmail.com>
-# vim: ts=4 et sw=4 sts=4
-
pkgname=gmt-cpt-city
-pkgver=2.19
-_pkgsubver=1
+pkgver=2.24
pkgrel=1
pkgdesc="GMT color palettes (*.cpt) from the cpt-city collection"
arch=('any')
url="http://soliton.vm.bytemark.co.uk/pub/cpt-city"
license=('GPL' 'APACHE' 'CCPL' 'custom')
optdepends=('gmt: the Generic Mapping Tools')
-source=(http://soliton.vm.bytemark.co.uk/pub/cpt-city/pkg/cpt-city_${pkgver}-${_pkgsubver}.tar.gz)
-install=$pkgname.install
-options=('!strip') #nothing to strip, takes ages trying
-md5sums=('daf52ae3f3520ba466690fd6eb22be98')
-
-build() {
- cd "$srcdir"/cpt-city-${pkgver}
- ./configure --prefix="$pkgdir"/usr --mandir="$pkgdir"/usr/share/man
-}
+source=("http://soliton.vm.bytemark.co.uk/pub/cpt-city/pkg/cpt-city-cpt-${pkgver}.zip")
+options=('!strip')
+sha512sums=('408838669aceb1114662215b4aaccfe83aabaafe2bff2075f9f7defe1a196183560fcf24c0e9d0098098d768672f85c7600ef652658c4f286141093937934dc6')
package() {
- cd "$srcdir"/cpt-city-${pkgver}
- make install
- mkdir -p "$pkgdir"/usr/share/licenses
- mv "$pkgdir"/usr/share/doc/cpt-city/copying "$pkgdir"/usr/share/licenses/$pkgname
- rm -rf "$pkgdir"/usr/share/doc
-
- #create symlink in gmt dir
- mkdir -p "$pkgdir"/usr/share/gmt/cpt "$pkgdir"/opt/gmt5/share/cpt/cpt-city
- # link for use with GMT5
- # ln -s /usr/share/cpt-city "$pkgdir"/opt/gmt5/share/cpt/cpt-city
- # link for use with GMT4
- ln -s ../../cpt-city "$pkgdir"/usr/share/gmt/cpt/GMT_cpt-city
+ install -d "${pkgdir}/usr/share/gmt/cpt"
+ cp -r cpt-city "${pkgdir}/usr/share/gmt/cpt/cpt-city"
}
+# vim: ts=4 sw=4: