summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c09d9c7c7c7a..bbb21e783a50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,8 @@ groups=('gnome-shell-extensions')
source=('git+https://github.com/repsac-by/gnome-shell-extension-quake-mode.git')
sha256sums=('SKIP')
+_uuid=quake-mode@repsac-by.github.com
+
pkgver() {
cd gnome-shell-extension-quake-mode
git describe --long --tags | sed 's/^v//;s/-/+/g'
@@ -22,18 +24,18 @@ pkgver() {
build() {
cd gnome-shell-extension-quake-mode
- gnome-extensions pack --force --extra-source={quakemodeapp,indicator,util}.js quake-mode@repsac-by.github.com
+ gnome-extensions pack --force --extra-source={quakemodeapp,indicator,util}.js "$_uuid"
}
package() {
cd gnome-shell-extension-quake-mode
- local destdir="$pkgdir/usr/share/gnome-shell/extensions/quake-mode@repsac-by.github.com"
+ local destdir="$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
install -d "$destdir"
- bsdtar -C "$destdir" --exclude schemas/ -xf quake-mode@repsac-by.github.com.shell-extension.zip
+ bsdtar -C "$destdir" --exclude schemas -xf "$_uuid.shell-extension.zip"
- install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" quake-mode@repsac-by.github.com/schemas/com.github.repsac-by.quake-mode.gschema.xml
+ install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" "$_uuid/schemas/com.github.repsac-by.quake-mode.gschema.xml"
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}