summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 673c6ee48aee..45c5f957d17e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=gnome-shell-extension-space-bar-git
_uuid=space-bar@luchrioh
-pkgver=22.r7.g89a4149
-pkgrel=2
+pkgver=33.r0.gb228b3a
+pkgrel=1
pkgdesc="GNOME Shell extension that shows workspaces buttons in top panel"
arch=('any')
url="https://github.com/christopher-l/space-bar"
-license=('unknown')
+license=('LicenseRef-unknown')
depends=('gnome-shell')
makedepends=('git' 'typescript')
provides=("${pkgname%-git}")
@@ -15,17 +15,17 @@ source=('git+https://github.com/christopher-l/space-bar.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/space-bar"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd space-bar
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/space-bar"
+ cd space-bar
sh scripts/build.sh
}
package() {
- cd "$srcdir/space-bar"
+ cd space-bar
install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
bsdtar -xvf "${_uuid}.shell-extension.zip" -C \
"$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner