summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b7546bc1c13..f4646f7b54d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=gnucash-xbt
_pkgname=gnucash
-pkgver=2.6.6
+pkgver=2.6.7
pkgrel=1
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
arch=('i686' 'x86_64')
url="http://www.gnucash.org"
license=("GPL")
-depends=('slib' 'goffice0.8' 'libdbi-drivers' 'libmariadbclient' 'postgresql-libs' 'aqbanking' 'desktop-file-utils' 'webkitgtk2' 'libgnome-keyring' 'libgnomecanvas')
+depends=('guile' 'slib' 'goffice0.8' 'libdbi-drivers' 'libmariadbclient' 'postgresql-libs' 'aqbanking' 'desktop-file-utils' 'webkitgtk2' 'libgnome-keyring' 'libgnomecanvas')
makedepends=('intltool')
optdepends=('evince: for print preview'
'yelp: help browser'
@@ -20,7 +20,7 @@ provides=('gnucash')
install=gnucash.install
source=("http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2"
"xbt.patch")
-sha1sums=('7a508743047202cc4c648ff188f92741010105a1'
+sha1sums=('93d51c45bdcc66bfcb1a1924622b48ca7f5ada17'
'7244b9cc71d0d03c43055c062f3eeba5e3544630')
prepare() {
@@ -42,7 +42,7 @@ package() {
make DESTDIR="${pkgdir}" install-info
install -dm755 "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${_pkgname}" --domain gnucash "${pkgdir}"/etc/gconf/schemas/*.schemas
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${_pkgname}.schemas" --domain gnucash "${pkgdir}"/etc/gconf/schemas/*.schemas
rm -f "${pkgdir}"/etc/gconf/schemas/*.schemas
# Delete the gnucash-valgrind executable because the source files
@@ -50,4 +50,7 @@ package() {
# to the location that it was built at.
rm -f "${pkgdir}"/usr/bin/gnucash-valgrind
+ # fix FS#45453
+ sed -i 's/exec gnucash-env [^[:space:]]*/exec gnucash-env guile/g' "${pkgdir}/usr/lib/gnucash/overrides/gnucash-make-guids"
+ rm "${pkgdir}/usr/lib/gnucash/overrides/guile"
}