summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f08b560a3a8a..24e469d677dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Miguel de Val-Borro <miguel@archlinux.net>
# Contributor: James Tappin <jtappinatgmaildotcom>
# Contributor: Orlando Garcia Feal <rodland at gmail dot com>
+# Contributor: Jan Kohnert <kohni.jk at gmail dot com>
pkgname=gnudatalanguage
pkgver=0.9.8
-pkgrel=2
+pkgrel=3
pkgdesc="An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)"
arch=('i686' 'x86_64')
url="http://gnudatalanguage.sourceforge.net/"
@@ -15,10 +16,17 @@ depends=('python2' 'python2-numpy' 'plplot510' 'gsl' 'readline' 'hdf5' 'netcdf'
makedepends=('cmake')
options=('!makeflags')
source=(http://downloads.sourceforge.net/gnudatalanguage/gdl-${pkgver}.tgz \
+ gdl-tirpc.patch \
gdl.profile)
md5sums=('451532f1263bbaa8745a4ca8978533c0'
+ 'cad6430a812e906ee7f1e15b4589dcac'
'40aa5fd8278cd8e80425c62a577563cc')
+prepare() {
+ cd $srcdir/gdl-${pkgver}/
+ patch -p1 < ../gdl-tirpc.patch
+}
+
build() {
cd $srcdir/gdl-${pkgver}
if [[ -d build ]]; then
@@ -34,6 +42,7 @@ build() {
-I/usr/lib/python2.7/site-packages/numpy/core/include" ..
make
}
+
package() {
cd $srcdir/gdl-${pkgver}/build
make DESTDIR=$pkgdir install