summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d118d8646e7c..5357323a04d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=gnuradio-git
_gitname=gnuradio
-pkgver=v3.11.0.0git.717.g72e21b54c
+pkgver=v3.11.0.0git.861.gd6bd59e94
pkgrel=1
pkgdesc="General purpose DSP and SDR toolkit, with drivers for usrp and fcd."
arch=('i686' 'x86_64')
url="https://github.com/gnuradio/gnuradio"
license=('GPL')
-depends=('fftw' 'python' 'python-numpy' 'python-mako' 'python-click' 'python-click-plugins' 'python-pyqt5' 'python-gobject' 'python-packaging' 'python-jsonschema' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.54' 'libusb' 'portaudio' 'libuhd' 'zeromq' 'libvolk' 'spdlog' 'gtk3')
+depends=('fftw' 'python' 'python-numpy' 'python-mako' 'python-click' 'python-pyqt5' 'python-gobject' 'python-packaging' 'python-jsonschema' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.54' 'libusb' 'portaudio' 'libuhd' 'zeromq' 'libvolk' 'spdlog' 'gtk3' 'libsndfile')
makedepends=('git' 'boost' 'cmake' 'python-cairo' 'python-yaml' 'python-cheetah3' 'glu' 'pybind11' 'qwt' 'python-sphinx')
optdepends=('python-lxml: Some GRC modules use lxml optionally for improved performance'
- 'python-qtpy: GNU Radio Companion requires this for the Qt-based front end')
+ 'python-qtpy: GNU Radio Companion requires this for the Qt-based front end'
+ 'python-pygccxml: Required by blocktool')
source=("git+https://github.com/gnuradio/gnuradio.git")
md5sums=('SKIP')
conflicts=('gnuradio' 'gnuradio-companion')
@@ -38,7 +39,7 @@ build() {
-DENABLE_INTERNAL_VOLK=OFF \
-DENABLE_GR_CTRLPORT=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGR_PYTHON_DIR=/usr/lib/python3.12/site-packages \
+ -DGR_PYTHON_DIR=/usr/lib/python3.13/site-packages \
-DQWT_LIBRARIES=/usr/lib/libqwt.so -Wno-dev ../
make
}