summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67d8c7b93e47..894e3740679a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
pkgname=gogios-bin
-pkgver=2.2.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="Checks to see if required services are still running on important machines."
arch=('x86_64')
url="https://angrysysadmins.tech"
license=('MIT')
optdepends=(
+ 'nmap'
+ 'sqlite'
'nginx'
'gogios-plugins'
)
@@ -15,10 +17,13 @@ source=("https://github.com/BKasin/gogios/releases/download/${pkgver}/gogios-${p
options=('!strip' '!emptydirs')
install=${pkgname}.install
noextract=("gogios-${pkgver}-${pkgrel}-${arch}.pkg.tar.xz")
-sha256sums=('521125ed75fb3b27b41298a7871bbe512d70e07ecc0fb3b813e62c1b85bf2293')
+sha256sums=('b7a0f1289ab2f8e5ce47862e68e76ea9978b042894afd82c866d8643aca02314')
provides=('gogios')
conflicts=('gogios')
+backup=(etc/gogios/{gogios.toml,checks.json})
+NoUpgrade=/etc/gogios/gogios.sample.toml
+
package() {
tar -xf gogios-${pkgver}-${pkgrel}-${arch}.pkg.tar.xz -C "${pkgdir}"
rm "${pkgdir}"/{.MTREE,.PKGINFO,.INSTALL}