summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d95fc7582383..73f5a427f3d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
-# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+# Maintainer: EndlessEden <eden [at] rose.place>
+# Contributor: deadite66 <lee295012@gmail.com>
+# Previous-Maintainer: Dan McCurry <dan.mccurry at linux dot com>
# Contributor: Yunhui Fu <yhfudev@gmail.com>
# Contributor: 0xfc <sfc_0@yahoo.com.cn>
# Modified from gr-osmosdr-git PKGBUILD
pkgname=gr-osmosdr-nonfree-git
-pkgver=0.1.4.72.g164a09f
-pkgrel=2
+pkgver=0.2.1.19.ga100eb0
+pkgrel=1
pkgdesc="GNU Radio source block for OsmoSDR with nonfree components, such as sdrplay, enabled."
arch=('i686' 'x86_64')
url="http://sdr.osmocom.org/trac/"
@@ -13,19 +15,20 @@ license=('custom')
depends=(
'gnuradio'
'swig'
+ 'rtl-sdr'
+ 'libuhd'
+ 'libmirisdr-git'
+ 'libosmosdr-git'
'airspy'
)
makedepends=(
'git'
'cmake'
'boost'
- 'python2-cheetah'
+ 'python-cheetah3'
)
optdepends=(
'gnuradio-iqbal: Osmocom IQ imbalance correction support'
- 'rtl-sdr-git: Osmocom RTLSDR support'
- 'libosmosdr-git: sysmocom OsmoSDR support'
- 'libmirisdr-git: Osmocom MiriSDR support'
'soapysdr-git: SoapySDR support'
'libsdrplay: SDRplay RSP support'
'gnuradio-fcdproplus: FUNcube Dongle Pro+ support'
@@ -63,9 +66,9 @@ build() {
cd "$srcdir/$_gitname"
mkdir -p build
cd build
- cmake -DPYTHON_EXECUTABLE=$(which python2) \
- -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2*) \
- -DPYTHON_LIBRARY=$(echo /usr/lib/libpython2.*.so) \
+ cmake -DPYTHON_EXECUTABLE=$(which python) \
+ -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python*) \
+ -DPYTHON_LIBRARY=$(echo /usr/lib/libpython.*.so) \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_NONFREE=TRUE ../
make