summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43f95b142379..14ca798c7cd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Arvid Norlander <VorpalBlade (at) users DOT noreply DOT github DOT com>
pkgname=greaseweazle
pkgver=1.16.3
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Tools for accessing a floppy drive at the raw flux level"
arch=('x86_64')
@@ -13,6 +13,12 @@ optdepends=('capsimage: Read IPF files')
source=("https://github.com/keirf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.zip")
sha256sums=('5a91d59186fc19ecd0ebe03914950739b9a98bccd4c324f810423b4478ea2715')
+prepare() {
+ cd "$pkgname-$pkgver"
+ # Workaround for https://github.com/keirf/greaseweazle/issues/430
+ sed -i "s/, '-Werror'//" setup.py
+}
+
build() {
cd "$pkgname-$pkgver"
python -m build --wheel --no-isolation