summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f1b859b868f..14fc574bad63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,19 @@ arch=('x86_64' 'i686' 'armv6h' 'armv7h')
url="http://potassco.sourceforge.net/"
license=('GPL3')
depends=()
-makedepends=('bison' 're2c' 'scons')
+makedepends=('patch' 'bison' 're2c' 'scons')
source=(
- "http://downloads.sourceforge.net/project/potassco/${pkgname}/${pkgver}/${pkgname}-${pkgver}-source.tar.gz")
-sha1sums=(5eb5e077cf9e1a87baf2c18322e431158090d656)
+ "http://downloads.sourceforge.net/project/potassco/${pkgname}/${pkgver}/${pkgname}-${pkgver}-source.tar.gz"
+ "https://sourceforge.net/p/potassco/bugs/_discuss/thread/5d530430/4fdf/attachment/include-math.patch.0"
+)
+sha1sums=(
+ 5eb5e077cf9e1a87baf2c18322e431158090d656
+ 52a073676bbf22859cc3f4566f5c2765f3a07876
+)
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}-source"
+ patch -p0 < "${srcdir}/include-math.patch.0"
scons --build-dir=release ${pkgname}
}