summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 812d26273c61..ed11a8900638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Frederik “Freso” S. Olesen <archlinux@freso.dk>
pkgname=gtksourceview3-fish-git
-pkgver=r1.86b94ce
-pkgrel=3
+pkgver=5.12.0.r7.g3b7476d
+pkgrel=1
pkgdesc='GtkSourceView3 syntax highlighting for fish shell scripts.'
arch=('any')
-url='https://github.com/fish-shell/fish-shell/issues/1812'
+url='https://gitlab.gnome.org/GNOME/gtksourceview/-/merge_requests/20'
license=('LGPL-2.1-or-later')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('fish-syntax::git+https://gist.github.com/1f811a567b180e9eeacd.git')
+source=('git+https://gitlab.gnome.org/GNOME/gtksourceview.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/fish-syntax"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C 'gtksourceview/' describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
depends=('gtksourceview3')
- cd "$srcdir/fish-syntax"
- install -Dm644 fish.lang "$pkgdir"/usr/share/gtksourceview-3.0/language-specs/fish.lang
+ install -Dm644 gtksourceview/data/language-specs/fish.lang "$pkgdir"/usr/share/gtksourceview-3.0/language-specs/fish.lang
}