summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0d66a533b7b..e587eaab823a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vinícius Moreira <vinicius_fmoreira@hotmail.com>
pkgname=guapow
-pkgver=1.3.3
+pkgver=1.3.4
pkgrel=1
pkgdesc="On-demand and auto performance optimizer for Linux applications"
arch=('any')
@@ -10,19 +10,22 @@ license=('zlib/libpng')
depends=('python' 'python-aiofiles' 'python-aiohttp' 'python-pycryptodome' 'systemd')
optdepends=('inxi: required for guessing the window compositor',
'unclutter: required for hiding the mouse cursor')
-makedepends=('git' 'python' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("${url}/archive/${pkgver}.tar.gz")
-sha512sums=('5c1f6806531e9c971fe1f651314093655ddbf356398399ab3e41944f257f24c52072e11ff606c73bced7056d69d01b616f27563d57cda2be427c32391af25663')
+sha512sums=('8a75f15fe30c5eb0d03e086a612742f27b8483bf62cb2ce8e54f569815e4fd1ff2f5d31b9715a6b1b915fe7b68a014a787571e1300e1054cf5e4f53a78ee4a12')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python3 setup.py build
- python3 setup.py test || return 1
+
+ # removing outdated setup files
+ rm setup.cfg setup.py requirements.txt
+
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
mkdir -p $pkgdir/etc/$pkgname
cp $pkgname/dist/daemon/opt.conf $pkgdir/etc/$pkgname/opt.conf.example