summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d9b50978fee..511bda8a12ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
-# Maintainer: Andrew Whatson <whatson@gmail.com>
-_pkgname=guile_curl
-pkgname=${_pkgname//_/-}
-pkgver=0.6
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+# Contributor: Andrew Whatson <whatson@gmail.com>
+
+pkgname=guile-curl
+pkgver=0.9
pkgrel=1
pkgdesc='A GNU Guile library for client-side URL transfers based on libcurl'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL3')
depends=('guile' 'curl')
-url="http://www.lonelycactus.com/guile-curl.html"
-source=("http://www.lonelycactus.com/tarball/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('e0304f67d66cb4b242a68368ba5b2680980b2a30113575e7337e2224a685addf')
+url="https://github.com/spk121/guile-curl"
+source=("https://github.com/spk121/guile-curl/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('d241f27c2a6d2ac768ce1ae64fd27e6854b34ace6ce35ce810fb41a2a7b20ed6')
build() {
- cd ${_pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
+ autoreconf -fiv
./configure --prefix=/usr
make
}
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
package() {
- cd ${_pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
}