summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec6555f21ccd..3e1a91b19eb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
_hkgname=hmenu
pkgname=haskell-hmenu
-pkgver=0.1.0.1
+pkgver=0.2.4.0
pkgrel=1
+commit=2877e58d0754acae015d28aae1ed2c94508969c5
pkgdesc="CLI fuzzy finder and launcher"
url="https://hackage.haskell.org/package/hmenu"
license=("BSD")
arch=('x86_64')
-depends=('ghc-libs' 'haskell-missingh')
+depends=('ghc-libs' 'haskell-missingh' 'haskell-tomland' 'haskell-bytestring-lexing' 'haskell-double-conversion' 'haskell-posix-paths')
makedepends=('ghc')
-source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
-sha256sums=('374320143bdac2e9771639b8d30492791c2c34641f496cea618ccbd0fdb7a37a')
+#source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
+source=(https://github.com/slotThe/hmenu/archive/$commit.zip)
+sha256sums=('17a7b55a36ffbab1de5232ee0897392e8bf8db51c127b12b0e0dcf3af53eff4a')
build() {
- cd $_hkgname-$pkgver
+ #cd $_hkgname-$pkgver
+ cd $_hkgname-$commit
+ echo -e "import Distribution.Simple\nmain = defaultMain" > Setup.hs
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
@@ -30,7 +34,8 @@ build() {
}
package() {
- cd $_hkgname-$pkgver
+ #cd $_hkgname-$pkgver
+ cd $_hkgname-$commit
install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh