summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7a5aaeb1b71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+# Maintainer: Jonathan Birk <cafce25@gmail.com>
+
+_hkgname=lambdabot-haskell-plugins
+pkgname=haskell-lambdabot-haskell-plugins
+pkgver=5.3.0.2
+pkgrel=1
+pkgdesc="Lambdabot Haskell plugins"
+url="https://wiki.haskell.org/Lambdabot"
+license=("custom:GPL")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-http' 'haskell-iospec' 'haskell-monadrandom' 'haskell-quickcheck' 'haskell-arrows' 'haskell-data-memocombinators' 'haskell-src-exts-simple' 'hoogle' 'haskell-lambdabot-core' 'haskell-lambdabot-reference-plugins' 'haskell-lambdabot-trusted' 'haskell-lifted-base' 'haskell-logict' 'haskell-mueval' 'haskell-network' 'haskell-numbers' 'haskell-oeis' 'haskell-regex-tdfa' 'haskell-show' 'haskell-split' 'haskell-syb' 'haskell-utf8-string' 'haskell-vector-space')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
+sha256sums=('f83fab2695fb0f9e2dd1a8dfc0e89e465a0d4bc4ccd9608db1a68cc19b414ec0')
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+} \ No newline at end of file