summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e8daae93309
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+# Maintainer: Jonathan Birk <cafce25@gmail.com>
+
+_hkgname=lambdabot-irc-plugins
+pkgname=haskell-lambdabot-irc-plugins
+pkgver=5.3.0.2
+pkgrel=1
+pkgdesc="IRC plugins for lambdabot."
+url="https://wiki.haskell.org/Lambdabot"
+license=("custom:GPL")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-safesemaphore' 'haskell-lambdabot-core' 'haskell-lifted-base' 'haskell-network' 'haskell-split')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
+sha256sums=('117f50ee74a2f1a271225c8fc07937e3b3f83766d859d2e0c69a1c02db3994df')
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+} \ No newline at end of file