summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e8837b95cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+# Maintainer: Jonathan Birk <cafce25@gmail.com>
+
+_hkgname=lambdabot-novelty-plugins
+pkgname=haskell-lambdabot-novelty-plugins
+pkgver=5.3.0.2
+pkgrel=1
+pkgdesc="Novelty plugins for Lambdabot"
+url="https://wiki.haskell.org/Lambdabot"
+license=("custom:GPL")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-brainfuck' 'dice' 'haskell-lambdabot-core' 'misfortune' 'haskell-random-fu' 'haskell-regex-tdfa' 'unlambda')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz"
+ "0001-Support-GHC-9.patch")
+sha256sums=('e0648f10e4761e982d6d1d09b70fd9655070867a99f09f9619e5cc0027d43827'
+ 'e3210154fe1ac2e4125a51526060efefb332e59239235317c6428e0626b254bc')
+
+prepare() {
+ cd $_hkgname-$pkgver
+
+ patch -p2 < ../0001-Support-GHC-9.patch
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}