summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f7bd3a3b512..22d0e43d7678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,20 @@
pkgname=hawknl
pkgver=1.70
-pkgrel=2
+pkgrel=3
pkgdesc="An open source game oriented network API"
arch=('i686' 'x86_64')
url="http://www.hawksoft.com/hawknl/"
license=('LGPL')
depends=('glibc')
-source=(https://github.com/dfyx/HawkNL/archive/master.zip)
-md5sums=('d972d5a697a10734c65f3426480331ad')
+source=(https://github.com/dfyx/HawkNL/archive/master.zip hawknl.patch)
+md5sums=('d972d5a697a10734c65f3426480331ad'
+ '7dec01dc297e2a4d3c515f6747dc5c9a')
build() {
cd "$srcdir"/HawkNL-master
- patch -Np2 --binary -i ../${pkgname}.patch
+ patch -Np2 --binary -i "${srcdir}/${pkgname}.patch"
make -f makefile.linux \
LIBDIR="$pkgdir"/usr/lib \
INCDIR="$pkgdir"/usr/include \